Issue
The NinjaOne Network Management (NMS) user interface incorrectly reports that a monitored NMS server is down or fails to populate the machine's syslog or NetFlow information.
Environment
NinjaOne NMS
Cause
NinjaOne's monitoring services cannot reach the NMS server.
Resolution
To resolve the issue, perform the following steps:
Verify Endpoint Status
Verify whether the endpoint is actually offline. From another endpoint on the same network, open a command-line session and ping the device's IP address. If the endpoint is unreachable, then it is either offline or not communicating on the network. NinjaOne will report devices in either state as "offline."
Check the NMS Configuration
- Verify that the server's NMS configuration is correct. Refer to NMS: Setup Installation and Configuration article.
- In NinjaOne, navigate to the Devices page.
- Click the name of the device you'd like to manage.
- Validate that the correct SNMP network discovery credentials are assigned to the server on the Settings tab.
Restart the NMS Server and Services
- Disable the NinjaOne services on the NMS server in the following order, ensuring that each is no longer running before disabling the subsequent one:
- Stop the NinjaOne NMS server service.
- Stop the NinjaOne NMS agent service. Doing so will force-close the NMS agent if it is open.
- Start the NinjaOne NMS server service. Ensure that it is running before continuing.
- Start the NinjaOne NMS agent service. Ensure that it is running before continuing.
- If NinjaOne continues to report that the endpoint is offline, restart the server through the service manager. For instructions about how to do so, refer to NMS: Restart Server Through Service Manager (Legacy).
Check the Server Logs
The NMS logs folder, located at % systemdrive%ProgramDataNinja Network ManagementNMS, may also contain helpful information. If there is a folder called "Logs" in the agent or server folder, the data it holds will include error codes that can help determine what is causing the device's communication issues.
If you are unsure what the error codes mean, provide them to NinjaOne Support for further review.
Additional Resources
For additional NMS troubleshooting help, refer to the following articles:
- NinjaOne Network Management: CPU, Memory, or Network Adapter Missing or Incorrect
- NinjaOne Network Management: Syslog or NetFlow Information Is Not Populating