Issue
Error states Device was not synchronized due to an internal error or experience with configurations not syncing properly.
Environment
- NinjaOne Integrations
- ConnectWise Manage
Cause
This error occurs when permissions are not configured correctly.
Resolution
Perform the following steps to resolve the issue.
- Verify that the user permissions are configured correctly in NinjaOne.
- Navigate to ConnectWise and confirm that the Add permission is included at Security Roles → System → Table Setup.
- Confirm the API user in ConnectWise Manage has the correct permissions as mentioned in ConnectWise REST API Key Set-Up. As an optional alternative, you can use the administrator role.
For NMS devices, verify that an NMS site is set up in ConnectWise to match the NinjaOne locations.
Additional Resources
We offer the following resources to help optimize the integration between your NinjaOne and ConnectWise Manage accounts:
- NinjaOne Integrations: Getting Started with ConnectWise Manage
- NinjaOne Integrations: ConnectWise Ticket Management
- NinjaOne Integrations: Map Devices to ConnectWise Configuration Types
- NinjaOne Integrations: Map Devices to ConnectWise Products and Agreements
- NinjaOne Integrations: Map Organizations to ConnectWise Companies
- NinjaOne Integrations: Run an Agreement Sync for ConnectWise Manage
- NinjaOne Integrations: ConnectWise Manage REST API Key Setup